01 June 2018

Dependencies

The following dependencies have been upgraded

  • org.codehaus.groovy:groovy-all:2.4.15

  • org.awaitility:awaitility:3.1.0

  • org.awaitility:awaitility-groovy:3.1.0

  • com.google.inject:guice:4.2.0

  • com.google.guava:guava:24.0-jre

  • org.jetbrains.kotlin:kotlin-stdlib:1.2.41

Runtime

Java8 Support

Previous versions provided Java8 specific support in an artifact named griffon-core-java8. This behavior is now found in griffon-core` there’s no need for an additional artifact.

Buildtime

Compatibility

Full binary compatibility report between Griffon 2.15.0 and 2.14.0 can be found here.

A list of fixed issues can be found at the 2.15.0 milestone page.